Implementing Basic Route Redistribution

redistribution example

Redistribution is a great way to work with a lot of routing protocols. Now it is time to configure “route redistribution” with an example ! And surely step by step. Please check the figure below :

basic redistribution example

1) Configure EIGRP and OSPF with no summarization. Loopbacks of the router 3 must be configured point-to-point.
2)
Activate full redistribution between OSPF and EIGRP networks. All routers must see all routes on the routing tables. Implement all metrics, pay attention that OSPF external routes shouldn’t increase their metrics.
3)
 Implement distribute-list filter on OSPF network so that just the “odd” loopbacks of the Router 1 is seen. All “even” subnets (including physical networks) shouldn’t be seen from OSPF domain side.
4)
Implement route-map filter so that just /24 routes are seen at EIGRP domain.

 

REDISTRIBUTION EXAMPLE CONFIG

R1(config)#router eigrp 100
R1(config-router)#network 10.0.0.0
R1(config-router)#no auto

R2(config)#router eigrp 100
R2(config-router)#network 10.1.12.0
R2(config-router)#no auto

 

 

We can’t use 10.0.0.0 0.0.0.255 because OSPF network is 10.x.x.x.x too !

R2(config)#router ospf 1
R2(config-router)#network 10.1.23.0  0.0.0.255 area 0

R3(config)#router ospf 1
R3(config-router)#network 10.0.0.0  0.255.255.255 area 0
R3(config)#interface range loopback0 - 6
R3(conf-if)#ip ospf network point to point     // Point-to-point configuration on router 3 loopbacks//

 

EIGRP default metric = infinite
OSPF default metric = 20     // Metric of EIGRP is infinite while metric of OSPF is 20 while passing over a network which uses another protocol via redistribution //

R2(config)#router ospf 1
R2(config-router)#redistribute eigrp 100 subnets     // Redistribution from EIGRP to OSPF network //
R3# sh ip route
...
10.1.3.0/24 [110/20] via 10.1.23.2

Route in EIGRP domain appears as an O(OSPF) route, not a D(EIGRP) metric=20 , E2 defaultly

R2(config)#router eigrp 100
R2(config-router)#redistribute ospf 1

If you run the “show ip route” after these commands ,you can’t see any entries in the routing table because of the infinite metric. So that we will use the commands below to resolve this issue

redistribute ospf metric 100 100 100 100 100     //  First 100 belongs to EIGRP BW, second DELAY , third RELIABILITY //


R3# sh ip route
D EX 10.1.11.0/30 [170/2613020] via 10.1.12.2

R2 (config)# access-list 1 permit 10.1.1.0  0.0.0.255
R2 (config)# access-list 1 permit 10.1.3.0  0.0.0.255
R2 (config)# access-list 1 permit 10.1.5.0  0.0.0.255

R2(config)#router ospf 1
R2(config-router)#distribute-list 1 out     //  OUT = While going to Router 3 from Router 2 //
R3# sh ip route 
OE2 10.1.3.0
OE2 10.1.1.0
OE2 10.1.7.0
OE2 10.1.5.0

R2(config)# ip prefix-list APPLE permit 10.0.0.0/8 le 24

You can permit a spesific subnet via prefix-list. In this command we are permitting 10.0.0.0/8 and less than or equal to. (le) For instance 10.5.0.0 / 16 will be permitted

R2(config)#route-map FILTER_OSPF_TO_EIGRP
R2(config-route-map)#match ip aress prefix-list APPLE
R2(config-route-map)#router eigrp 100
R2(config-route-map)#redistribute ospf 1 metric 100 100 100 100 100 route-map FILTER_OSPF_TO_EIGRP

*** We could do this last step via distribute-list too

Leave a Reply

Your email address will not be published. Required fields are marked *